#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)I(?:'| a)?m (.*)"
Local $sString = "I'm hungry" & @CRLF & _
"It's hot outside and I'm hungry" & @CRLF & _
"I'm stupid and hungry" & @CRLF & _
"I'm with stupid" & @CRLF & _
"Im hungry"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")