import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?!0\\d)\\d+\\.?\\d*$";
final String string = "0.500\n"
+ "3\n"
+ "0\n"
+ "0.0\n"
+ "30\n"
+ "0.\n"
+ "500000\n"
+ "4000.22\n"
+ "0.50\n\n"
+ ".3\n"
+ ".44\n"
+ "00\n"
+ "00.5\n"
+ "03.3\n"
+ "00\n"
+ "02\n"
+ "00.0\n"
+ "03\n"
+ "-03\n"
+ "-01\n"
+ "-01.\n"
+ "0004";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}