# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?(?!0\d)\d+\.?\d*$"
test_str = ("0.500\n"
"3\n"
"0\n"
"0.0\n"
"30\n"
"0.\n"
"500000\n"
"4000.22\n"
"0.50\n\n"
".3\n"
".44\n"
"00\n"
"00.5\n"
"03.3\n"
"00\n"
"02\n"
"00.0\n"
"03\n"
"-03\n"
"-01\n"
"-01.\n"
"0004")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.