# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\t ]+/ /g;t' <<< "Hello World!
Tab and space inside.
trailing tab
Nothing special."