#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\t ]+"
Local $sString = "Hello World!" & @CRLF & _
"Tab and space inside." & @CRLF & _
"trailing tab " & @CRLF & _
"Nothing special."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)