import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]+:\\/\\/[^\\/,#?]*\\K[^,\\n]*";
final String string = "https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,\n"
+ "https://community.domain.tld/register?tests,categorie,dateAcces,,,\n"
+ "https://community.domain.tld/register,categorie,dateAcces,,,\n"
+ "https://community.domain.tld/,categorie,dateAcces,,,\n"
+ "https://community.domain.tld,categorie,dateAcces,,,\n"
+ "https://community.domain.tld?to=dfgdfgdgf,categorie,dateAcces,,,\n"
+ "https://community.domain.tld#dfgdfgdgf,categorie,dateAcces,,,\n"
+ "https://community.domain.tld,categorie,dateAcces,,,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}