# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" [^.]*"
test_str = ("icon-culture (2015_09_04 06_58_44 UTC).png\n"
"icon-disk (2015_09_04 06_58_44 UTC).png\n"
"icon-download (2015_09_04 06_58_44 UTC).png\n"
"icon-drop (2015_09_04 06_58_44 UTC).png\n"
"icon-file (2015_09_04 06_58_44 UTC).png\n"
"icon-film (2015_09_04 06_58_44 UTC).png\n"
"icon-flag (2015_09_04 06_58_44 UTC).png\n"
"icon-folder (2015_09_04 06_58_44 UTC).png\n"
"icon-garbage (2015_09_04 06_58_44 UTC).png\n"
"icon-graph (2015_09_04 06_58_44 UTC).png\n"
"icon-heart (2015_09_04 06_58_44 UTC).png\n"
"icon-help (2015_09_04 06_58_44 UTC).png\n"
"icon-lock (2015_09_04 06_58_44 UTC).png\n"
"icon-map (2015_09_04 06_58_44 UTC).png\n"
"icon-media (2015_09_04 06_58_44 UTC).png\n"
"icon-money (2015_09_04 06_58_44 UTC).png\n"
"icon-monitor (2015_09_04 06_58_44 UTC).png\n"
"icon-notes (2015_09_04 06_58_44 UTC).png\n"
"icon-openmail (2015_09_04 06_58_44 UTC).png\n"
"icon-phone (2015_09_04 06_58_44 UTC).png\n"
"icon-photo (2015_09_04 06_58_44 UTC).png")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.