const regex = /IMG[0-9]*.webp/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('IMG[0-9]*.webp', 'gm')
const str = `<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG541585829284482.webp\\" style=\\"width: 320px; height: 82px;\\" /></p>\\n\\n<p><img alt=\\"\\" src=\\"https://lomabucket.s3.ap-northeast-2.amazonaws.com/loma_test_image/event_image/IMG101585824307864.webp\\" style=\\"width: 320px; height: 340px;\\" /></p>\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}