const regex = /^\/cms\/api\/preview\/(.*)\/([a-zA-Z]{2}-[a-zA-Z]{2})\/([a-zA-Z0-9-_\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/cms\\\/api\\\/preview\\\/(.*)\\\/([a-zA-Z]{2}-[a-zA-Z]{2})\\\/([a-zA-Z0-9-_\\\/]*)(.*?)(?(4)([a-zA-Z0-9-_=&]*)|)$', 'mg')
const str = `/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123
/cms/api/preview/pippo/paperino/en-US/pluto/DePaperoni/paperoga?qui=qua&quo=qui&cap-paperopoli=123
/cms/api/preview/pippo/en-US/pluto23?qua=qui
/cms/api/preview/pippo-clarabella/EN-us/123???
/cms/api/preview/pippo/en-US/pluto-orazio?
/cms/api/preview/pippo/paperino/en-US/pluto/minni/amelia
Output for Nginx:
/preview/\$1/\$3?lang=\$2&\$5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}