const regex = /\{(?:(?:\{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\})|(?:[^{}]))*\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(?:(?:\\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\})|(?:[^{}]))*\\}', 'g')
const str = `captures up to singly-nested blocks:
p{1} = \\{(?:[^{}])*\\}
int main() {
return 0;
}
captures up to doubly-nested:
p{2} = \\{(?:(?:p{1})|(?:[^{}]))*\\}
...or...
p{2} = \\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\}
void more_complex_fxn(int z) {
int x = z / 9;
if (x > 3) {
do_something;
x += 5;
}
}
Following the pattern set above...
up to triply-nested:
p{3} = \\{(?:(?:p{2})|(?:[^{}]))*\\}
...or...
p{3} = \\{(?:(?:\\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\})|(?:[^{}]))*\\}
double so_many_blocks(double x) {
double y = x;
while(y > 4) {
if (y < 6) {
y -= 0.3;
} else {
y -= 0.5;
}
}
return y;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}