import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<product_name>^.*)[-]((?P<ver>\\*|\\d+(\\.\\d+){0,2}(\\.\\*)?))[-](?P<build>.\\d*)[.](?P<ext>bin|rpm)$";
final String string = "anomali_match-4.4.0-5352.rpm\n"
+ "anomali_link_universal-4.4.0-36.bin\n"
+ "anomali_link_ESM-4.4.0-1234.bin\n"
+ "anomali_link_universal_2.4.0_hotfix-2.tar.gz\n"
+ "Anomali-Ulink-4.5-2139.rpm\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}