Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$
"
gm
Input 1
1
New
anomali_match-4.4.0-5352.rpm anomali_link_universal-4.4.0-36.bin anomali_link_ESM-4.4.0-1234.bin anomali_link_universal_2.4.0_hotfix-2.tar.gz Anomali-Ulink-4.5-2139.rpm