const regex = /\b(?:skewY?|rotate|matrix)\([0-9]+[a-zA-Z]*(?:, ?[0-9]+[a-zA-Z]*)*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:skewY?|rotate|matrix)\\([0-9]+[a-zA-Z]*(?:, ?[0-9]+[a-zA-Z]*)*\\)', 'gm')
const str = `skew(1deg)
rotate(3)
skewY(10deg)
matrix(0, 0, 0, 0, 0, 0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}