// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b\w{30,1000})?\b").unwrap();
let string = "http://www.youtube.com/watch?v=qsXHcwe3krw
http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg
enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}