using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select\s.*\sfrom\s(\S+)\s*";
string input = @"select Count_Big(*) from dbo.Orders orderby date desc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}