package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)select\s.*\sfrom\s(\S+)\s*`)
var str = `select Count_Big(*) from dbo.Orders orderby date desc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}