package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@([^\s.,;]+)`)
var str = `asdfasdf @test1, asdf./,a fasdfasdf fasdfasdf
sertiosdf;gk gsdfgsdfijgioj 4gsdkg @username42;i`
var substitution = "<a href="$1">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}