$re = '/^(\w+)=(.*)/m';
$str = 'A=10
B=11';
$subst = "\"$1\":\"$2\",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;