import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2><a href=\"(.+?)\" title=\"(.+?)\"";
final String string = " <div class=\"category-title\">\n"
+ " <span class=\"category-viewall\"><a href=\"/предавания/сезон-2016\" title=\"Виж всички\">Виж всички ></a></span>\n"
+ " <h2><a href=\"/предавания/сезон-2016\" title=\"Предавания Сезон 2016\">Сезон 2016</a></h2>\n\n"
+ " </div>\n"
+ " <div class=\"category-objects\">\n"
+ " <a href=\"560-строеж-на-сграда-хидроизолация-на-основи-зидане-на-вътрешни-стени\" class=\"category-object\" title=\"Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени\">\n"
+ " <div class=\"object-thumb\">\n"
+ " <div class=\"play-icon\"></div>\n"
+ " <div class=\"duration-icon\">22:11</div> <img src=\"/object_images/tvshows/thumbs/9_32_stroej_sgrada.jpg\" alt=\"Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени\"/></div>\n"
+ " <div class=\"object-title\"><h3>Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени</h3></div>\n\n"
+ " </a>\n"
+ " <a href=\"559-зидане-на-външни-стени-и-завършването-им-с-топлоизолационни-системи-за-клинкер-или-естествени-камъни\" class=\"category-object\" title=\"Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни\">\n"
+ " <div class=\"object-thumb\">\n"
+ " <div class=\"play-icon\"></div>\n"
+ " <div class=\"duration-icon\">22:27</div> <img src=\"/object_images/tvshows/thumbs/9_31_vunshni_steni.jpg\" alt=\"Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни\"/></div>\n"
+ " <div class=\"object-title\"><h3>Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни</h3></div>\n\n"
+ " </a>\n"
+ " <a href=\"558-плъзгаща-врата-иновации-в-обзавеждането-на-кухнята\" class=\"category-object\" title=\"Плъзгаща врата, иновации в обзавеждането на кухнята\">\n"
+ " <div class=\"object-thumb\">\n"
+ " <div class=\"play-icon\"></div>\n"
+ " <div class=\"duration-icon\">21:57</div> <img src=\"/object_images/tvshows/thumbs/9_30_pluzgashta_vrata.jpg\" alt=\"Плъзгаща врата, иновации в обзавеждането на кухнята\"/></div>\n"
+ " <div class=\"object-title\"><h3>Плъзгаща врата, иновации в обзавеждането на кухнята</h3></div>\n\n"
+ " </a>\n"
+ " <a href=\"557-саморазливна-замазка-обръщане-на-прозорци-измазване-на-стена-фина-шпакловка\" class=\"category-object\" title=\"Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка\">\n"
+ " <div class=\"object-thumb\">\n"
+ " <div class=\"play-icon\"></div>\n"
+ " <div class=\"duration-icon\">21:08</div> <img src=\"/object_images/tvshows/thumbs/9_29_samorazlivna_zamazka.jpg\" alt=\"Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка\"/></div>\n"
+ " <div class=\"object-title\"><h3>Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка</h3></div>\n\n"
+ " </a>\n"
+ " </div>\n"
+ " <div class=\"category-title\">\n"
+ " <span class=\"category-viewall\"><a href=\"/предавания/сезон-2015\" title=\"Виж всички\">Виж всички ></a></span>\n"
+ " <h2><a href=\"/предавания/сезон-2015\" title=\"Предавания Сезон 2015\">Сезон 2015</a></h2>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}