#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d*\.\d*px"
Local $sString = "110px" & @CRLF & _
"" & @CRLF & _
"0.2px" & @CRLF & _
"" & @CRLF & _
"99.999999999px" & @CRLF & _
"" & @CRLF & _
"56.25%" & @CRLF & _
"" & @CRLF & _
".4753729px" & @CRLF & _
"" & @CRLF & _
"66.px"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")