import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*\\.\\d*px";
final String string = "110px\n\n"
+ "0.2px\n\n"
+ "99.999999999px\n\n"
+ "56.25%\n\n"
+ ".4753729px\n\n"
+ "66.px";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}