const regex = /\d*\.\d*px/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*\\.\\d*px', 'g')
const str = `110px
0.2px
99.999999999px
56.25%
.4753729px
66.px`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}