#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(https?:\/\/(?!www))"
Local $sString = "the url is http://google.com http://www.google.com https://google.com https://google.com"
Local $sSubst = "$1www."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)