// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/(\d+)/?").unwrap();
let string = "https://www.dndbeyond.com/profile/Gadianton/characters/16837355
ddb.ac/characters/16837355/sfmp2b
https://www.dndbeyond.com/characters/16837355/sfmp2b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}