$re = '/^(?!CG.*AG.*AG)CG.*AG$/m';
$str = 'CGUUAG
CGCGUCAG
AGUCGUAG
CGAGAG
UUAGAGCUUAGC
CGCGCGAG
CGAG
AAGCCU
GACU';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);