import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*\\(Hex\\): w*)(.*?)(?= |$)";
final String string = " Vserver Name: vs1\n"
+ " LUN Path: /vol/vol1/lun1\n"
+ " Volume Name: vol1\n"
+ " Qtree Name: \"\"\n"
+ " LUN Name: lun1\n"
+ " LUN Size: 10MB\n"
+ " OS Type: linux\n"
+ " Space Reservation: disabled\n"
+ " Serial Number: wCVt1]IlvQWv\n"
+ " Serial Number (Hex): 77435674315d496c76515776\n"
+ " Comment: new comment\n"
+ "Space Reservations Honored: false\n"
+ " Space Allocation: disabled\n"
+ " State: offline\n"
+ " LUN UUID: 76d2eba4-dd3f-494c-ad63-1995c1574753\n"
+ " Mapped: mapped\n"
+ " Block Size: 512\n"
+ " Device Legacy ID: -\n"
+ " Device Binary ID: -\n"
+ " Device Text ID: -\n"
+ " Read Only: false\n"
+ " Fenced Due to Restore: false\n"
+ " Used Size: 5MB\n"
+ " Maximum Resize Size: 64.00GB\n"
+ " Creation Time: 9/14/2016 13:55:09\n"
+ " Class: regular\n"
+ " Node Hosting the LUN: node1\n"
+ " QoS Policy Group: -\n"
+ " Caching Policy Name: -\n"
+ " Clone: false\n"
+ " Clone Autodelete Enabled: false\n"
+ " Inconsistent Import: false\n"
+ " Application: -";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}