$re = '/<[^<>]*>(*SKIP)(*F)|-/m';
$str = '<a href=\'dd-ccc\'>dd-ccc</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);