import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\.)(?!.*\\.$)(?!.*?\\.\\.)([a-zA-Z0-9.!#$%&'*+\\/=?^_`\\{|\\}~-]+)@((?!\\.)(?!.*\\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$";
final String string = "pete@openanswers.co.uk\n"
+ "pete.Davies@openanswers.co.uk\n"
+ "pete.Da!#$%&'*+vies@openanswers.co.uk\n"
+ "pete.Davies@open-answers.co.uk\n"
+ "pete.Davies.@openanswers.co.uk\n"
+ "pete.Davies@.openanswers.co.uk\n"
+ "pete.Davies@openanswers.co.uk-\n"
+ "pete.Davies@openanswers.co.uk.\n"
+ "pete.Davies@openanswers.co..uk\n"
+ "pete..Davies@openanswers.co.uk\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}