$re = '/^([\wÀ-ú ]+ - ){2}[\wÀ-ú]+$/m';
$str = 'abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);