package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^-]+ - ){2}[^- ]+$`)
var str = `abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _
÷÷ - ÷ - ÷÷÷
- - x
-- [^-] pega quebras de linha
abc - fad
fdas - fda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}