package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-]?\d+(\.\d+)?`)
var str = `1
-1
1
12
-12
12.5
-12.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}