import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://\\S+/([^\\s/]+\\.pdf)$";
final String string = "http://www.oldsite.com.au/*.pdf\n"
+ "https://www.newsite.com/wp-content/uploads/2021/01/*.pdf\n"
+ "http://www.test.com/a.b.c.pdf";
final String subst = "replacement $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}