$re = '`https?://\S+/([^\s/]+\.pdf)$`m';
$str = 'http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf';
$subst = "replacement $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;