# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?://\S+/([^\s/]+\.pdf)$"
test_str = ("http://www.oldsite.com.au/*.pdf\n"
"https://www.newsite.com/wp-content/uploads/2021/01/*.pdf\n"
"http://www.test.com/a.b.c.pdf")
subst = "replacement $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.