using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \K&(?= .* & )";
string substitution = @",";
string input = @"GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}