use strict;
my $str = 'http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com';
my $regex = qr/([a-z]+)(?=[^a-z\r\n]*\.[a-z]{2,6}$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";