# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-z]+)(?=[^a-z\r\n]*\.[a-z]{2,6}$)"
test_str = ("http://www.mywebsiteameW1234.com\n"
"https://www.mywebsiteameW1234.com\n"
"http://mywebsiteameW1234.com\n"
"https://mywebsiteameW1234.com")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.