import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\>)(\\d{4}\\-\\d{2}\\-\\d{2}T\\d{2}\\:\\d{2}\\:\\d{2}Z)(?=<\\/span)";
final String string = "<p><span data-date=\"2019-05-10\" data-time=\"19:00:00\" class=\"discourse-local-date\" data-timezones=\"Europe/Brussels\" data-timezone=\"Europe/Berlin\" data-email-preview=\"2019-05-10T17:00:00Z UTC\">2019-05-10T17:00:00Z</span> → <span data-date=\"2019-05-10\" data-time=\"22:00:00\" class=\"discourse-local-date\" data-timezones=\"Europe/Brussels\" data-timezone=\"Europe/Berlin\" data-email-preview=\"2019-05-10T20:00:00Z UTC\">2019-05-10T20:00:00Z</span><br>\n"
+ "<div class=\"lightbox-wrapper\"><div class=\"meta\">\n"
+ "<span class=\"filename\">HackSpace_by_Sugar_Ray_Banister.jpg</span><span class=\"informations\">1596×771 993 KB</span><span class=\"expand\"></span>\n"
+ "</div></a></div></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}