import re
regex = re.compile(r"\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))", flags=re.MULTILINE)
test_str = ("// \"/Structure\" package\n"
"data-source structurePackage = userPkg/packagedElement[Package|name=\"Structure\"]\n"
" \n"
"synctable-schema ComponentsSchema {\n"
" record dim [Class|mse::metaclassName=\"SysML::Blocks::Block\"]{\n"
" key column /name as PublicId\n"
" column /ownedAttribute[Property|mse::metaclassName=\"MD Customization for SysML::additional_stereotypes::ValueProperty\", name=\"label\"]/defaultValue[LiteralString]/value as Label\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")