const regex = /(http[s]?)\:\/\/([\w\-_]+(\.[\w\-_]+){0,5}(\:\d+)?)((\/[\w\.\-_]+\/?)*)\/?(\?([\w\._\-]+\=[\w\.\-_\s+%]*\&?)*)?(\#[\w_\/\-]*)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?)\\:\\\/\\\/([\\w\\-_]+(\\.[\\w\\-_]+){0,5}(\\:\\d+)?)((\\\/[\\w\\.\\-_]+\\\/?)*)\\\/?(\\?([\\w\\._\\-]+\\=[\\w\\.\\-_\\s+%]*\\&?)*)?(\\#[\\w_\\\/\\-]*)?', 'gi')
const str = `https://regex101.com/users/
https://regex101.com/users/?query=1
https://regex101.com/users/?query=1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);