$re = '`\d{1,2}/\d{2}(?:/\d{4})?`m';
$str = '5/21 or 5/21/2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);