package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?(?:\d+[\d,]*)?\.?\d+`)
var str = `7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}