package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^abc\h*-\h*((?:[^\s-]+(?:\h+[^\s-]+)*)?)`)
var str = `abc - xyz
abc - pqr - xyz
abc - - xyz
abc - pqr uvw - xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}