re = /\[([^\]]+)\]\(([^"“”]+)(?: [\"|\“]([^\"“”]+)[\"|\”])?\)/
str = '[some text](http://google.com "title")
[some text](http://google.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end