using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^-]+-(.+\.(png|jpg))\)";
string input = @"(background_apartment_450-533c-d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.png)
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg)
background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}