use strict;
my $str = '(background_apartment_450-533c-d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.png)
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg)
background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5)';
my $regex = qr/\([^-]+-(.+\.(png|jpg))\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}