# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/([ac])\\/(\d{1,4})\\/(\d{1,4})\\/([a-zA-Z\d\._-]+)\\/(.*)//x;t' <<< "/a/94/403/webolizer/1461075495.84270.webmail5581.mynet.com%3A1228350129winmail.dat"