use strict;
my $str = '/a/94/403/webolizer/1461075495.84270.webmail5581.mynet.com%3A1228350129winmail.dat';
my $regex = qr/^\/([ac])\/(\d{1,4})\/(\d{1,4})\/([a-zA-Z\d\._-]+)\/(.*)/xp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";