using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\""[^\""]*\"",){3})\""[^\""]*\""|\""[^\""]*\""$";
string substitution = @"$1""";
string input = @"""00001"",""Open"",""2020-10-23 12:45"",""2022-10-20 15:48"",""Error not found"",""Alex Smith"",""NO ERROR"",""ErrorApp"",""FOB"",""CNSHA"",""GB"",""Plane"",""MODEL"",""2020-10-24 00:00"",""New"",""1"","",""2022-10-20 15:48""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}