using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n";
string input = @"
4nY6zVk61Z(\x010\x0205\x0202\n
4nY8GkxuEy(\x010\x0201\x0202\n
4nYA5W4GtJ(\x010\x0205\x0202\n
4nY6zVk61Z(\x010\x0205\x0202\n
4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n
4nY8spkhEULA1701\x0276\x0276\x011(\x012(\n
\x02([0-9]{2})\x02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}